企业网站建设

建站知识

今日已发布信息: 288502
累计注册用户: 63133696

1.6-常见的502问题解决

概述: 所以造成502。如果是监听的IP,则没有这个问题。ls /tmp/wyp.sock 可以看到其他没有任何权限,这时候有两种解决办法:1:修改/tmp/wyp.sock的权限777  (临时起效,服务重启后失效)2:在/usr/local/php/etc/php-fpm.conf中,监听nginx的身份nobody配置如下:在服务配置中插入以下代码listen = /tmp/wyp.socklisten.owner = nobodylisten.group = nobody因为wyp.sock是php启动后产生的文件,nginx默认没有权限

在使用nginx打开论坛时,网站根目录正确,但是打开网页502

这这时候可以查看nginx的错误日志,在配置文件中有定义:/usr/local/nginx/logs/nginx_error.log

可以看到 unix:/tmp/wyp.sock failed (13: Permission denied)这一行,说明nginx没有权限读取sock文件,所以造成502。如果是监听的IP,则没有这个问题。

ls /tmp/wyp.sock 可以看到其他没有任何权限,这时候有两种解决办法:

1:修改/tmp/wyp.sock的权限777  (临时起效,服务重启后失效)

 

  无锡免费网站设计  第一金   今日推荐免费建站   分类信息   吐鲁番网站建设公司

 

2:在/usr/local/php/etc/php-fpm.conf中,监听nginx的身份nobody

配置如下:在服务配置中插入以下代码

listen = /tmp/wyp.sock

listen.owner = nobody

listen.group = nobody


因为wyp.sock是php启动后产生的文件,nginx默认没有权限。

监听nginx的用户身份后,才给予权限读取。



个人疑问:

1.lamp环境下,discuz的目录需要改为daemon.才有读写权限安装

2.lnmp环境下,discuz的目录需要改为php-fpm才有读写权限安装

是不是,我可以认为,discuz是一个php的安装脚本或程序,php要执行,必须的有相关目录的权限。apache因为是调用php模块,模块属于自身的一部分。所以php的相关操作,身份还是apache本身。即daemon

而nginx只是代理了php,把相关请求转交给php,最终的执行身份是php-fpm。所以这里的所有者有了区别。

 

Baidu竞价推广控制成本 不失精准推广的技术

  怎样才能降低百度推广的成本费用?相信很多人都关注这个话题,随着线上交易产品的极具增加,百度竞价推广系统也逐步完善各项功能,商家可以通过对竞价账户的优化,实现控制竞价推广成本又不失精准推广。 

  做竞价推广首先需要清理自己的理解误区,很多人最初对竞价排名的概念都是“价高者靠前”其实不然,随着百度竞价推广系统不断的完善,如今关键词排序位置不在单凭出价决定,能影响其排序位置的因素范围较广,当中比较突出的关键词质量度、高质量创意撰写,都已参与到影响关键词排序位置的行列。

  我个人在搜索引擎营销领域,更擅长SEO免费的推广技术(SEO是什么意思?)当然竞价推广无疑是效果更显著,但任何有利于产品成交的方法都值得学习。做SEO或许你只需要关注排名和成交量,但竞价推广你会更关注推广成本,下面我分享一些不仅能节约推广成本,并且不失精准推广的技巧,解决每个新手都曾遇到过的问题。

 

  账户推广地域

  不难理解就是你产品或服务所针对用户所在地域,通过对推广地域的设置不仅能做到精准推广,同时也算便向节约推广成本的方式之一。例如:你的产品只面向北京地区用户销售,排除品牌知名度方便的宣传外,如果你的产品推广链接展示在全国所有城市,将意味着推广成本和产品成交量会无限的拉开距离。 

 

  设置每日预算

  通过对竞价账户每天预算支出金额的设置,可有效见面不必要的超支情况出现,当然理应是结合多方数据分析得出的结果。例如:收集每天到某一时间段的大概消费,持续几天后你会得出一个理性的结果。设置预算不仅是控制成本的操作,同时是防御危机事件的应急措施,比较常见的防御恶意点击措施之一。

  

  关键词选择技巧

  正确的关键词选择方式会有助于推广营销,整合全局你会发现此操作也是控制成本的根源,并且是直接影响产品成交量的一个选项,合理的关键词选择方式有助于控制成本,同时也是精准推广的核心操作。如上图所示:某些关键词每日搜索量较大,相反它的竞争力度却不是那么激烈,经常分析这样的数据会有助于正确的选择关键词。

  安装流量统计

  其实站长统计工具相信都不会陌生,但总会看到有人忽略这个关键技巧,而且还不停的问人家如何节约竞价成本。此话题没什么好说的百度流量统计工具很实用,竞价推广账户的后台也有引导讲解,你不去了解谁也拿你没办法。拓展思维:通过对网站访客流量的统计,可以清晰看到自己的钱都用在哪,同时也会是控制竞价成本的参考资料。

  否定关键词设置

  前面说到了站长统计此时重要性凸显,通过流量统计数据分析,你能清晰看到用户是如何进入你网站的,重要的关键词搜索信息也会被统计到。分析这些用户搜索的关键词,排除一些非目标客户的搜索行为,把关键词添加至后台的否定工具选项中,能有效控制竞价成本并做到更精准的推广效果。 

  设置IP排除选项

  通过排除非目标客户IP的设置,可有效预防恶意点击、降低成本、精准推广,通常建议认真分析用户行为后在操作,当然此功能也被广泛的运用在缩小推广地域,例如排除一些县级城市的IP地址,让你的推广信息更精准的展示在目标客户面前。

  写在最后的总结:

  现在网上有很多自称能优化竞价账户的软件,很容易就有急于求成的新手上当受骗,当然并非所有的软件都不能用,只是维尚个人会建议你远离这些系统化的东西。

从中午点餐想到的网站运营战略

  今天在在上班过程中,突然想起来好久没有在外面点餐了,遂拿起电话准备的时候却发现没有号码可拨,那么直接在百度上找寻吧,看到一家合肥的点餐网站,就想着看看中午点餐中,结果看到这个网站之后,突然想提笔写一些网站运营和点餐这个小事情挂钩的感悟了。

  首先看一下网站首页截图,看到图之后,就想起了这个网站针对运营所作的哪些方式了吧,毕竟很多网站都是需要好好分析之后才会得到结论的。

  

 

  当看到这个网站的时候,就很诧异,为什么它会脱颖而出,现在的美食类的大多数都被58同城啊,赶集网之类的都填充,剩下的市场真的很少很少,因为很多外卖的店铺商家不会每家每户都去做一个网站,毕竟太过于花费精力,那么在赶集网站,58同城上打一个宣传就是十分方便的事情,但是对于我们站长来说,这就给我们压力的网页了,但是怎么做才能独自占据一份市场,有一下几点可以参考下了。

  其实这个网站的seo做的挺强大了,直接截图看百度权重可以得到一下资料。

  

 

  不过今天想说的网站运营和点餐的方面,可以看到这个网站和本地化的商户有很深的联系,杭州外卖,网上订餐等等关键字都在首页;现在有很多的工作者都喜欢去外面吃,但是天气炎热起来之火,点餐就会火起来,那么这一点中,我们就可以看到,点餐点餐,更多的需求在哪里,就在我们之中,我们普通的上班族就是消费者,但是消费水平去不会很高,这一点一定是需要好好考虑的,那么看下如下的网站如何呢?

  

 

  从这个网站本身的功能上来说,网站功能有些多,有餐厅,下午茶,水果,礼品,江湖等等的形式,不过笔者认为做好首先应该好好做好一个网站功能,然后从一个功能延伸到另一个网站功能,这样才能进一步的提高自己的网站管理能力,毕竟现在一般朋友都是独自的努力着,分散精力不如集中突破。所以,如果网站中,以点餐为主,其他为辅,主攻点餐的话,会更加有效,而且现在杭州上班族如此之多,只要服务化,不怕巷子深,会附带着购买越来越多你们的服务,这些人中,虽然消费不高,但是有着良好的口碑宣传,毕竟口碑才是营销推广最给力的利器。

  下面就说下如何运用好这样的网站吧,毕竟好网站做起来也是很不容易的。

  一:引导用户的习惯问题

  其实前期对于用户来说接触一个新网站需要一个途径,那么我们就可以通过写字楼发传单,然后上面写上今天打折的商家店铺,已经商品,然后引导用户去网站注册,然后订餐,前期的时候,一定要注重网站的打开速度已经订餐之后送到的速度,这个一定要做好初步体验,而且如果感觉好的话,会有很多很多的回头客,毕竟你做了一个别人没做的事情,那就是收集每天打折的菜品和店铺,这就是你的优势,引导用户的习惯,就是让用户来到你的网站成为一种习惯,吃就是一种主流,那么你的网站就需要和主流挂钩起来。

  二:从用户的个人点餐记录中分析数据

  后期的话,记得从海量的数据中提炼出个人的爱好(关于吃的部分),做出这部分数据之后,你就知道他爱吃什么,什么水果,什么菜肴,等等,然后可以做一些EDM营销,通过邮件发送来为每个人推荐好菜,每天的打折店铺,每天去哪里吃自己爱吃的食品,慢慢的掌握一个人的爱好,其实互联网的以后,就会出现一个个通过数据知道你的爱好的人,而且是为每个人订做的分析报告。

怎样使用单机单网卡实现公司内、外网访问

  在我所将要实施的一个项目中,某公司内部有两套网络系统实现内、外网的物理隔离,员工访问内、外网时使用的双网卡隔离器来切换实现上不同的网络。而随着业务和科技的进步,用户需要布署一套桌面云系统,用桌面云来打造内、外网络,在前端使用云终端一体机来连接桌面云服务器登陆桌面访问。这样一来就会产生很多问题:

  1、因用户前期在将要布署桌面云系统的每个云终端位置只布置了一根网线,不是象其它公司要使用内、外网络都是在每个终端前布两根网线来切换不同网络。

  2、云终端一体机上也只有一个网口,无法实现双网口隔离访问内、外网络。

  这里我想即然无法象一般的内、外网访问采用物理隔离方案,那我就只有采用网络逻辑隔离方案拉(化分不同的VLAN,使用ACL来隔离内、外网)。我在这个项目中使用超融合一体化服务器系统、Vmware Horizon6、华为万兆核心交换机、华为千兆接入交换机、外网防火墙、WEB防火墙、IPS、云终端一体机等软、硬件设备,系统的部分拓扑图如下:

 在上面的拓扑图可以看出,在云终端一体机和千兆接入交换机之间是使用超五类网线连接,超融合一体化服务器系统和万兆交换机之间是使用SFP+多模模块来实现连接,在万兆核心交换机上一个电口连接内网光纤专线,一个电口连接外网防火墙出Internet网,在外网防火墙和核心交换机之间透明布署一台IPS,在接入交换机和核心交换机之间布署一台WEB防火墙(给内网用户使用,保护WEB站点)。

  为了更好的在实施过程中不出现问题,我就自己搭了个实验环境来走一遍,我的实验拓扑图如下:

  1、在拓扑图中我把IPS和WEB防火墙给简化掉了,不妨碍模拟真实的过程。

  2、我使用VMware Workstation软件安装一台WIN2008 R2系统来模拟内、外网桌面系统。

  3、我再使用VMware Workstation软件安装一台WINXP系统来模拟终端用户。

  4、我使用华为的eNSP来模拟核心、接入交换机系统。

  5、我使用VMware Workstation软件安装Panabit来模拟防火墙系统,使用上外网功能。

  6、在功能上要实现,终端用户能分别正常访问内、外网桌面云,而内、外网桌面云不能互相访问(来实现内、外网逻辑隔离)。

  7、外网桌面云可以正常上Internet,需内网桌面云不能上Internet。

  华为eNSP网络拓扑图如下:

 

  1、在核心交换机分别创建VLAN 17、20、50、100

  2、分别设置每个VLAN的网关为254

  3、VLAN50可以访问VLAN17、20,VLAN17和VLAN20不能相互访问

  4、VLAN17可以访问外网,其余VLAN拒绝访问外网

  5、外网桌面云VM是接入VMware Workstation虚拟网VMnet1

  6、内网桌面云VM是接入VMware Workstation虚拟网VMnet2

  7、终端用户是接入VMware Workstation虚拟网VMnet3

  8、panabit是接入VMware Workstation虚拟网VMnet4

  9、panabit另一个网卡桥接在本机物理网卡上

  其中接入交换机的配置如下:

#

sysname sw2   #重命名为SW2

#

vlan batch 17 20 50 100  #建立VLAN17 20 50 100 

#

interface GigabitEthernet0/0/1

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094    #进入G0/0/1接口,做Trunk模式,允许所有VLAN通过

#

interface GigabitEthernet0/0/2

 port link-type access

 port default vlan 50     #进入G0/0/2接口,做access模式,化入VLAN50

#

  核心交换机的配置如下:

<Huawei>system-view

[Huawei]sysname sw1

[sw1]vlan batch 17 20 50 100    #创建不同的VLAN

[sw1]interface g0/0/1      #进入G00/0/1口

[sw1-GigabitEthernet0/0/1]port link-type access

[sw1-GigabitEthernet0/0/1]port default vlan 17    #化入VLAN17

[sw1-GigabitEthernet0/0/1]qu

[sw1]interface g0/0/2      #进入G00/0/2口

[sw1-GigabitEthernet0/0/2]port link-type access 

[sw1-GigabitEthernet0/0/2]port default vlan 20    #化入VLAN20

[sw1-GigabitEthernet0/0/2]qu

[sw1]interface g0/0/3      #进入G00/0/3口

[sw1-GigabitEthernet0/0/3]port link-type trunk 

[sw1-GigabitEthernet0/0/3]port trunk allow-pass vlan all   #建TRUNK,允许所有VLAN通过

[sw1-GigabitEthernet0/0/3]qu

[sw1]interface vlan 17

[sw1-Vlanif17]ip address 172.16.17.254 255.255.255.0   #指定VLAN17的网关

[sw1-Vlanif17]qu

[sw1]interface vlan 20

[sw1-Vlanif20]ip address 192.168.20.254 255.255.255.0  #指定VLAN20的网关

[sw1-Vlanif20]qu

[sw1]interface vlan 50

[sw1-Vlanif50]ip address 192.168.50.254 255.255.255.0  #指定VLAN50的网关

[sw1-Vlanif50]qu

[sw1]interface vlan 100

[sw1-Vlanif100]ip address 10.10.10.254 255.255.255.0   #指定VLAN100的IP地址

[sw1-Vlanif100]qu


[sw1]acl number 3000   #配置VLAN17到VLAN20的访问规则

[sw1-acl-adv-3000]rule deny ip source 172.16.17.0 0.0.0.255 destination 192.168.

20.0 0.0.0.255

[sw1-acl-adv-3000]qu

[sw1]traffic classifier c_vlan17   # 配置流分类c_vlan17,对匹配ACL 3000的报文进行分类

[sw1-classifier-c_vlan17]if-match acl 3000

[sw1-classifier-c_vlan17]qu

[sw1]traffic behavior b_vlan17     # 配置流行为b_vlan17,动作为拒绝报文通过

[sw1-behavior-b_vlan17]deny 

[sw1-behavior-b_vlan17]qu

[sw1] traffic policy p_vlan17  # 配置流策略p_vlan17,将流分类c_vlan17与流行为b_vlan17关联

[sw1-trafficpolicy-p_vlan17] classifier c_vlan17 behavior b_vlan17

[HUAWEI-trafficpolicy-p_market] quit

[sw1]interface g0/0/1         # 将流策略p_vlan17应用到GE0/0/1接口

[sw1-GigabitEthernet0/0/1]traffic-policy p_vlan17 inbound 

[sw1-GigabitEthernet0/0/1]qu


[sw1]interface g0/0/24

[sw1-GigabitEthernet0/0/24]port link-type access 

[sw1-GigabitEthernet0/0/24]port default vlan 100  #化入VLAN100

[sw1-GigabitEthernet0/0/24]qu

[sw1]ip route-static 0.0.0.0 0.0.0.0 10.10.10.10  #配置默认路由到外网防火墙

<sw1>save

  把交换机的配置全部配置好后,我再到VMware Workstation中安装好WIN2008 R2、WINXP系统,这个过程很简单我就不再描述过程,只是讲解怎么把系统接入到不同的网络中来做实验。

 1、把WINXP接入VMNET3网络中

  2、把WINXP的IP地址设置为192.168.50.3,网关为192.168.50.254。

  3、用PING命令,看是否能PING通网关。

  4、先把WIN2008 R2接入VMNET1网络中

  5、把WIN2008 R2的IP地址设置为172.16.17.2,网关为172.16.17.254.

  6、用PING命令,看是否能PING通网关。

  7、在WIN2008 R2系统中安装IIS服务,然后把默认网站启用,因很简单我这里不做介绍。到WINXP系统中用IE浏览器输入172.16.17.2看能否打开默认网站。如果能则表示从云终端能够正常访问外网桌面云系统。

  8、然后我们再把WIN2008 R2系统接入到VMNET2网络中,模拟内网桌面云系统

  9、把WIN2008 R2的IP地址修改为192.168.20.2,网关为192.168.20.254

  10、用PING命令,看是否能PING通网关。

  11、到WINXP系统中,用IE浏览器输入192.168.20.2看能否打开默认网站。如果能则表示从云终端能够正常访问内网桌面云系统。用相同的方法测试外网桌面云系统172.16.17.2也是可以打开网站,这里不再重复描述。全部测试完成则表示云终端是可以分别正常访问内、外网系统的。

  12、因我只有WIN2008和XP两个系统,所以我再把WINXP接入到VMNET1,来模拟下外网桌面云系统

  13、我把WINXP的IP地址修改为172.16.17.3,网关为172.16.17.254

  14、然后用PING命令,来PING192.168.20.2,来测试看我在核心交换机上做ACL能否起来拒绝内、外网互访的功能。如果不能PING通则表示已起到内、外网隔离功能。

  15、再到WIN2008 R2系统中去PING172.16.17.3,如果不能PING通则表示已起到内、外网隔离功能。

  16、在这里我是用Panabit软件来模拟防火墙,真实的实现内部设备上Internet的功能。先在VMware Workstation中安装好Panabit。在Panabit系统中我使用了三块网卡,第一块接入VMNET3网络,当管理接口。第二块接入VMNET4网络,和核心交换机相连。第三块网卡接入VMNET0网络,桥接到我的物理网卡,模拟Internet。

  17、进入系统后输入用户名root和密码panaos.

  17、使用ifconfig来查看三块网卡的地址,用ifconfig le0 192.168.50.10 255.255.255.0命令来给管理网口设备IP地址。

  18、在自己的物理机的浏览器上输入192.168.50.10地址,来WEB管理Panabit。

  19、在此点击继续浏览此网站,输入用户名admin,密码panaos

  20、进入页面后,我进入系统维护-升级系统,把补丁给打好。

  21、进入系统维护-管理接口,设置好接口地址,并提交。

  22、进入系统维护-数据接口,分别的其余两块网卡接入内、外网,并提交。

  23、进入应用路由-接口线路,分别设置LAN接口和WAN接口

  24、点击LAN接口-添加,设置接口名inside,IP地址10.10.10.10,网络掩码255.255.255.0,其余默认不用改。

  25、点击WAN接口-添加,设置接口名outside,IP地址192.168.1.200,网关为192.168.1.1(这是我家里光猫的地址),DNS也是192.168.1.1.

  26、点击应用路由-策略路由,设置好内网访问外网的策略,源地址172.16.17.0/24(外网云地址),做NAT出外网。

  27、把WINXP接入VMNET2,模拟内网桌面云,PING192.168.1.1,看能否上Internet,打开网页也无法访问。实现了内网桌面云无法上Internet的功能。

  28、把WIN2008 R2接入VMNET1,模拟外网桌面云,PING192.168.1.1,看能否上Internet,打开网页可以访问百度。实现了外网桌面云可以上Internet的功能。

  29、我在最后了又测试了另外一个功能,就是在Internet访问内网服务器的功能,先把WIN2008 R2接入VMNET1,设好IP地址172.16.17.2,网关为172.16.17.254,DNS为192.168.1.1。在Panabit上,应用路由-端口映射,如下图所示:

  30、然后在物理机上,使用IE浏览器输入IP地址192.168.1.200(相当于公网地址),结果可以正常访问,功能测试正常。

  最后所有的实验和结果都做完了,功能都全部实现,当然有人可能会用更好的方法和做法,我这里只是给大家一个借鉴,希望能对大家在以后的项目工程中有所帮助。


站长们为何都喜欢骂Baidu

  百度是一个在搜索领域和技术都十分强大的公司,他们要的未来要发展的更加完善是无可避免的事情。每当我的网站被K了,我首先第一点会想想自己的站为何会被封,然后就知道下一步该怎样做站了。因为网站的全部环节,都是自己经手的,意识上很自然就已经有了大概的答案,所以整个过程花了才不到才几分钟的时间而已。

  可是,很多站长第一时间却不是去关心自己的明天,反而是去关心正在骂百度有共同遭遇的人,可能这样会让某些人觉得自己不是唯一的倒霉鬼,至少知道还有其他人正在陪伴自己受罪,心理上会好受些。最后,自己不知不觉也被同一等级的人所感染跟着去一起骂,直到形成了大事小事不骂百度不舒服的习惯。

  

 

  但其实,那些天天都在骂百度的人,你有没有想过你真的应该去骂吗?骂,可能除了帮你升高血压、减轻心理负担、让同行觉得你可能很懂之外,就根本起不了任何的经济推动作用,当你正在骂或者关心别人正在骂的时候就已经倒退了,也让别人知道你原来是属于多么弱小的群体中的人。

  随便开骂,其实是无补于事

  我虽然平时不是太喜欢看电影,但是也建议大家看看《硅谷传奇》与《社交网络》。

  比尔盖茨:有时候你与他们交往,有时候你与他们翻脸。扎克伯格:我只是感觉他们事与愿违。请好好学习前辈们的思维,学习别人的处事心态。想做一个理智的人,骂、其实只是一种形式,在工作上千万不要因为事与愿违而开骂。而且,阳光小宅博客一直认为,能够在互联网上面混的很多前辈,都是有一个像比尔和扎克那样无比强大的心态,当有需要正确面对问题的时候,可以把人的情绪保持正确的方式去看待。

  正如乔布斯,心态也一样更加强大。只会确立有共同利益的人去做敌人,当对手一旦确定,就必须下定决心去超越对方,否则说多了,而又但不到目的,最后受伤的只是自己的内心受到打击。所以理智的人,是不会做任何浪费精神的蠢事,否则拉拢回来的只有一大堆懂得怨天尤人的骂鬼。在国内最典型的例子,除非是周鸿那样,有实力可以通过自己的形式捍卫认为是属于自己的利益。

  

 

  现实中,自从我真正懂事开始,就慢慢的变得理智,不会随便对任何事开骂。包括,在互联网上这个非面对面的神奇国度,也不会为了一时的痛快而出卖自己的理智去骂。在做SEO方面,任何一个搜索引擎不管是什么理由要封我的网站,我也是觉得是无可厚非的事情。因为我相信自己和很多站长都是很理智的,明白过去做站是完全是为了利用搜索引擎公开的漏洞使用SEO手段而获得排名的,现在这种方式的成功几率比较难了也是预料中的事情。

  我曾经使用百度进行搜索一点资料,然后进入了时曾相识的网站。当时我心里面想像这个网站,为什么可以排在前面。后来经过我仔细研究,感觉眼前的这个站的模板怎么那么面熟,最后才发现眼前的这个网站是自己的,最后搞到有点哭笑不得。

  如果过去没有百度,我相信自己和很多站长都要搞尽脑汁地做一切更苦力的推广工作。就因为有百度的存在,过去把网站做好了,然后放上广告,狂做SEO工作,最后就可以做到守株待兔的方式达到盈利。曾经就因为百度,给了自己就有那么多时间在别人上班的时候自己就逛街,人家加班的时候自己却在看电视,人家睡觉的时候自己在吃宵夜,人家带着熊猫眼去上班的时候自己正在呼呼入睡。曾经的一切就像做梦一样,发生得太美妙的。

  通常喜欢骂百度的往往是一下这五类人

  1、专家类

  SEO专家现在少之又少,成名的早已成名,绝世高手也退隐二线了。虽然自己不是很懂SEO,但是也感觉这种人说话简直狗屁一通。一时说这个因素、一时又那个诸多的因素,自己最后失败了就说成人工干预等一切可以推卸的理由。每当百度有什么大风吹草动的时候,就跑出来不断带头骂百度,试图引起有同一命运的站长产生共鸣后得到别人的谅解,掩饰自己并非是技术没到家而导致失败的事实,同时也提升了自己的曝光率,简直一举两得。我不太是认同这种人的做法,可是采用胡说八道的方式来误人子弟就太不应该了。

  2、草根类

  真正的草根站长一般的都是非常踏实的,没有多少资源、没有多少技术。把网站做起来后,多数就是靠SEO手段日复一日辛勤地耕耘,当有了不错的收入就会获得很满足,感觉这一些都是靠自己的辛勤劳动得到了。可是这一类型的站长在心灵上是非常脆弱的,当某一天自己的网站被百度封了后,就会认为别人抢走了他理所当然的一切,在网络上能够说话的地方不断骂,不断发泄自己的愤怒,希望引起别人的重视。

  3、炫耀类

  无论成败都喜欢公之于世的一类型人群。当获得成功的时候不断分享自己的经验,就是为了得到别人的认同,也没有太多的其他原因。当失败的时候,更加是不可能承认是自己的失败,不太肯接受现实的人。总是希望通过骂人的言论方式去改变自己在世人眼中的印象,永远都只是想把自己塑造是一个成功者形象。结果就永远只有在失败的时候不断骂百度,永远在为失败找理由。

  4、混日子

  多数这一类型人都是在一些IT公司上班的,拿死工资的那种居多。如果没有任何人指点,是不会有任何的创新手法,永远跟着别人陈旧的足迹去走,只是掌握了一点的SEO常识,大概就是为了获得一份稳定点的薪水而又听起来有点体面的工作而工作。上面交代下来的任务,每天就是机械性地完成任务,运气好的话总会有几个网站有不错的排名。当百度一改变算法的时候,业绩下降了,自己的利益没有了,骂百度这个那个没人性,又或者到处哭诉自己是多么勤奋、有多么不容易。

  5、门外汉

  不懂装懂、喜欢走捷径的一类人。有时候感觉真的很可怕,当别人怎么骂百度,自己也跟着去骂。目的都是想以占便宜的方式快速进入到一个群体里面,然后利用身边人的一些名气,试图在别人交往的过程中自己可以快速吸收别人的经验,也想利用别人的影响力帮助到自己的发展。这种人多数都是听说SEO很赚钱,然后自己也做几个垃圾站来玩,人骂的时候自己也骂,希望在骂的过程中得到别人的接纳,让别人看起来是同一路的人。但是,当真正接触起来的时候,99%是会露馅的。

  总结

  何时该骂,何时不该骂,这个抉择的标准,是极道德的。因为,骂是一种高深的学问,不要因为某些儿戏的原因而染上了随便骂的习惯,否则对个人的将来会带来不乐观的情绪化影响。

  因为SEO的原因感觉到愤怒,就真的不要再骂百度了,因为你们都不是百度的对手,骂了又起不了任何作用就只会证明你更加没用。而且,通常骂百度的站长都是自己瞄准百度来做垃圾站,平时那头自己也使用百度进行搜索内容,结果搜出了个垃圾站,就大骂百度搜索用户体验差,然后又到K站的时候,大骂百度搜索引擎的算法不公平。而我就从来没有听过普通网民会骂百度不好用的,有的都是站长类的人。

众说纷纭的静态化 究竟对优化有无好处

  论坛中经常说看到站长们咨询:网站优化时网址是否需要静态化,有的站长会坚持要网站静态化,但是也会发现一些大型的网站仍然使用的是动态地址,网站的静态化真的是众说纷纭,其实对于SEO来说,静态化是最基本的要求之一,从一定程度上来说,静态化的网址更利于蜘蛛的抓取,深圳兼职吧给站长们说说静态化对优化的益处。

  首先:蜘蛛害怕抓取复杂的链接,现在的网站的页面都是由程序实时生成的,用户访问一个网址时,程度会根据访问中网址中的参与调用数据库,实时的生成页面内容,这些URL中都包含了很多符合、问号、或者一些杂乱的参数,如下面使用ASP语言做的企业网站动态地址:http://www. jianzhi8.com/news.asp?cat_id=40&news_id=300,对于这样的复杂的长连接地址,蜘蛛是很不愿意抓取,害怕可能会遇到无限的循环连接、或者是危险的垃圾链接、或者是网站中存在的大量重复的内容,所以对于网站要想能被充分的收录,还是建议站长把动态的URL地址转化为静态的URL地址,也减少蜘蛛的抓取困难,同时静态的URL地址也更容易被用户记住和使用。

  其次:迎合更多的搜索引擎抓取网站,在Google官方发布声明说网站可以不用静态化,Google蜘蛛表明完全有能力抓取动态的地址,甚至说动态的地址更有利于蜘蛛的抓取,但是这一声明仅仅是针对Google本身的搜索引擎,目前为止除Google以外的搜索引擎更青睐于静态的地址。只要站长们能把网站的静态化设置正确,不要在设置网页静态时,把Session ID也放入静态地址,蜘蛛来网站抓取时,会正确的抓取到网站中的静态地址。

  还有:提高网站程序的性能,特别对于一些大型的网站来说,网站使用动态的地址,用户以不同的入口进入网站,都会产生一个不同的动态地址,这样的访问会给网站加载带来负担,但是如果给网站设置静态后,在用户访问之前就能直接获取资源或数据库数据进而通过静态化处理,生成静态页面,所有人都访问这一个静态页面,而静态化处理的页面本身的访问速度要较动态页面快很多倍,因此程序性能会有大大的提升。

  对于网站是静态还是动态,互联网界都将是众说纷纭的,不管怎么说这两者的优缺点,这里再给大家说说动态网址怎样才能静态化,给大家分析几个不同程序的静态化方法:

  1. wordpress博客静态,WP博客是现在个人站长使用比较多的博客程序,要想静态化也是很容易的,使用WP No Category Base 插件,安装后在链接设置中选择自定义结构:/%category%/%post_id%.html 这样的链接设置后,并可自动生成伪静态。

  2. Linux Apache服务器,使用服务器中的URL重写模块,使用mod_rewrite模块,在.htaccess文件中写入代码:RewriteRule/products/([0-9]+)/products.php?id=$1。

  3. Discuz论坛,在论坛的后台优化设置中,找到搜索引擎优化,把URL 静态化的几项都选上,然后点击保存。然后生成一个.htaccess(如果是windows系统则用httpd.ini)放到论坛根目录下:

  < IfModule mod_rewrite.c >

  RewriteEngine On

  RewriteBase /

  # Rewrite 系统规则请勿修改

  RewriteRule ^archiver/([a-z0-9-]+.html)$ archiver/index.php?$1

  RewriteRule ^forum-([0-9]+)-([0-9]+).html$ forumdisplay.php?fid=$1&page=$2

  RewriteRule^thread-([0-9]+)-([0-9]+)-([0-9]+).html$ viewthread.php?tid=$1&extra=page\%3D$3&page=$2

  RewriteRule ^space-(username|uid)-(.+).html$ space.php?$1=$2

  RewriteRule ^tag-(.+).html$ tag.php?name=$1

  < /IfModule >

  4. 不过没个网站的动态URL结构都不同,服务器的设置也可能不同,代码也就设置的不一样,要设置静态最好是程序员进行编写,以免不必要的错误,影响静态页的生成。

  其实不从优化的角度来说,动态地址和静态地址也是没有区别的,如果站长觉得自己的网站不需要使用SEO优化,仅仅是为了展示企业风采,那静态化也是没什么必要的。

http://www.kvov.com.cn/jzxx25030.html

今日推荐知识库
标语口号
只要有彩虹出现,明天就一定有希望。
解梦
青年人梦见蛇头则近期运程,和顺,尊重他人的意见,就能获得大好时运。
唐诗三百首
彼美岩石,谁施黼藻功。回岩明照地,绝壁烂临空。锦段鲜须濯,罗屏展易穷。不因秋藓绿,非假晚霞红。羽客藏书洞,樵人取箭风。灵踪理难问,仙路去何通。返驾归尘里,留情向此中。回瞻画图畔,遥羡面山翁。
语录
爱情既是世界上最坚定的东西,又是最不堪一击的东西。信念坚定,爱情自然就坚定,三天两头闹分手的人是因为爱情还不够刻骨铭心,只有当你把它看作生命中的唯一时,它才是坚不可摧的!
经典语录
因为不爱,所以都错。